<!DOCTYPE html>

<html lang="en-US">

	<head>
		<title>Bri’s picks of the week: coming-of-age movies - The Current Sauce</title>
		<meta charset='UTF-8' />
<meta name='viewport' content='width=device-width, initial-scale=1, maximum-scale=3' />
<meta name='dcterms.audience' content='Global' />

<!-- This site is optimized with the Yoast SEO plugin v13.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Bri’s picks of the week: coming-of-age movies - The Current Sauce" />
<meta property="og:description" content="Brianna Corley Arts and Living Editor Coming-of-age&nbsp;is&nbsp;a concept that has filled countless novels and artwork.&nbsp;What films have best shown the many sides and stories of growing into yourself? In this week’s picks, we will be exploring the some of the most impactful coming-of-age movies. “Lady Bird”&nbsp;– 2017 Following its titular character Christine “Lady Bird” MacPherson &hellip;" />
<meta property="og:url" content="https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/" />
<meta property="og:site_name" content="The Current Sauce" />
<meta property="article:publisher" content="https://www.facebook.com/thecurrentsauce/" />
<meta property="article:author" content="https://www.facebook.com/thecurrentsauce/" />
<meta property="article:section" content="Arts &amp; Living" />
<meta property="article:published_time" content="2020-03-30T21:07:08+00:00" />
<meta property="article:modified_time" content="2020-03-30T21:07:11+00:00" />
<meta property="og:updated_time" content="2020-03-30T21:07:11+00:00" />
<meta property="og:image" content="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&#038;ssl=1" />
<meta property="og:image:width" content="512" />
<meta property="og:image:height" content="512" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Brianna Corley Arts and Living Editor Coming-of-age&nbsp;is&nbsp;a concept that has filled countless novels and artwork.&nbsp;What films have best shown the many sides and stories of growing into yourself? In this week’s picks, we will be exploring the some of the most impactful coming-of-age movies. “Lady Bird”&nbsp;– 2017 Following its titular character Christine “Lady Bird” MacPherson [&hellip;]" />
<meta name="twitter:title" content="Bri’s picks of the week: coming-of-age movies - The Current Sauce" />
<meta name="twitter:site" content="@thecurrentsauce" />
<meta name="twitter:image" content="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&#038;ssl=1" />
<meta name="twitter:creator" content="@thecurrentsauce" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://currentsauce.com/#website","url":"https://currentsauce.com/","name":"The Current Sauce","inLanguage":"en-US","description":"Northwestern State University&#039;s student newspaper since 1914","potentialAction":[{"@type":"SearchAction","target":"https://currentsauce.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&ssl=1","width":512,"height":512},{"@type":"WebPage","@id":"https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/#webpage","url":"https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/","name":"Bri\u2019s picks of the week: coming-of-age movies - The Current Sauce","isPartOf":{"@id":"https://currentsauce.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/#primaryimage"},"datePublished":"2020-03-30T21:07:08+00:00","dateModified":"2020-03-30T21:07:11+00:00","author":{"@id":"https://currentsauce.com/#/schema/person/4987d28eec7f99367582230b7d82c41e"},"potentialAction":[{"@type":"ReadAction","target":["https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/"]}]},{"@type":["Person"],"@id":"https://currentsauce.com/#/schema/person/4987d28eec7f99367582230b7d82c41e","name":"The Current Sauce","image":{"@type":"ImageObject","@id":"https://currentsauce.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/29bdbf179c81e792cbb60613931f7b33?s=96&d=blank&r=pg","caption":"The Current Sauce"},"sameAs":["https://www.facebook.com/thecurrentsauce/","https://twitter.com/thecurrentsauce"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Current Sauce &raquo; Feed" href="https://currentsauce.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Current Sauce &raquo; Comments Feed" href="https://currentsauce.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Current Sauce &raquo; Bri’s picks of the week: coming-of-age movies Comments Feed" href="https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/feed/" />
<!-- This site uses the Google Analytics by ExactMetrics plugin v6.0.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.0.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-113901301-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-113901301-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/currentsauce.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- currentsauce.com is managing ads with Advanced Ads --><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wpcom-text-widget-styles-css'  href='https://currentsauce.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/text-media-widget-styles/css/widget-text.css?ver=20170607' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://currentsauce.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='onionbuzz-viral-quiz-frontend-css-frontend.css-css'  href='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/frontend/css/frontend.css?ver=1.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='onionbuzz-viral-quiz-vendors-animations-animations.css-css'  href='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/vendors/animations/animations.css?ver=1.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='st-font-custom-css'  href='//fonts.googleapis.com/css?family=Playfair+Display%22+rel%3D%22stylesheet%22%3E' type='text/css' media='all' />
<link rel='stylesheet' id='st-font-custom-2-css'  href='//fonts.googleapis.com/css?family=Fira+Sans+Condensed%22+rel%3D%22stylesheet%22%3E' type='text/css' media='all' />
<link rel='stylesheet' id='st-shortcodes-css-css'  href='https://currentsauce.com/wp-content/themes/Truemag/assets/css/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto-css'  href='https://currentsauce.com/wp-content/plugins/stkit/components/lightbox/assets/css/prettyPhoto.css' type='text/css' media='screen' />
<link rel='stylesheet' id='tt-easy-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Ovo%3Aregular%7CAssistant%3A300%2C600%2C800%2C700&#038;subset=latin%2Call&#038;ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='st-style-css'  href='https://currentsauce.com/wp-content/themes/Truemag/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-css'  href='https://currentsauce.com/wp-content/plugins/newsletter/style.css?ver=6.5.8' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;display=fallback&#038;ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://currentsauce.com/wp-content/plugins/stkit/assets/plugins/mediaelement/mediaelementplayer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='popup-maker-site-css'  href='//currentsauce.com/wp-content/uploads/pum/pum-site-styles.css?generated=1585219893&#038;ver=1.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='st-responsive-css'  href='https://currentsauce.com/wp-content/themes/Truemag/assets/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='st-custom-css'  href='https://currentsauce.com/wp-content/uploads/truemag_custom.css' type='text/css' media='screen' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.3/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/currentsauce.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.0.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/jquery.jetpack-resize.min.js'></script>
<link rel='https://api.w.org/' href='https://currentsauce.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://currentsauce.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://currentsauce.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p9DHrS-39t' />
<link rel="alternate" type="application/json+oembed" href="https://currentsauce.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcurrentsauce.com%2F2020%2F03%2F30%2Fbris-picks-of-the-week-coming-of-age-movies%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://currentsauce.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcurrentsauce.com%2F2020%2F03%2F30%2Fbris-picks-of-the-week-coming-of-age-movies%2F&#038;format=xml" />
<!-- start Simple Custom CSS and JS -->
<style type="text/css">
.blog #content-container {
width: 100%;
}

.blog #sidebar {
display: none;
}</style>
<!-- end Simple Custom CSS and JS -->

<!-- Onionbuzz Custom CSS -->
<style type="text/css">

</style>
<!-- Onionbuzz Custom CSS END -->
<script type="text/javascript">window.onionbuzz_params = {"ajax_url":"https:\/\/currentsauce.com\/wp-admin\/admin-ajax.php","is_mobile":false};</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel='Shortcut Icon' href='https://i2.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?ssl=1&amp;resize=107%2C107' type='image/x-icon' />
<!-- All in one Favicon 4.7 --><link rel="shortcut icon" href="https://currentsauce.com/wp-content/uploads/2018/02/favicon.ico" />
<link rel="icon" href="https://currentsauce.com/wp-content/uploads/2018/02/favicon-32x32.png" type="image/png"/>
<link rel="apple-touch-icon" href="https://currentsauce.com/wp-content/uploads/2018/02/apple-touch-icon.png" />
<style type="text/css" id="custom-background-css">body.custom-background { background-color: #efefef; }</style>
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=270%2C270&#038;ssl=1" />
<script>UA-113901301-1</script>
			<style type="text/css" id="wp-custom-css">
				.entry-content li {
    font-size: 12px;
    font-family: "Mate";
}			</style>
		<style id="tt-easy-google-font-styles" type="text/css">p { font-family: 'Ovo'; font-style: normal; font-weight: 400; text-decoration: none; text-transform: none; }
h1 { font-family: 'Assistant'; font-style: normal; font-weight: 300; text-decoration: none; text-transform: none; }
h2 { font-family: 'Assistant'; font-style: normal; font-weight: 600; text-decoration: none; text-transform: none; }
h3 { font-family: 'Assistant'; font-style: normal; font-weight: 800; text-decoration: none; text-transform: none; }
h4 { font-family: 'Assistant'; font-style: normal; font-weight: 800; text-decoration: none; text-transform: none; }
h5 { font-family: 'Assistant'; font-style: normal; font-weight: 700; text-decoration: none; text-transform: uppercase; }
h6 { font-family: 'Assistant'; font-style: normal; font-weight: 800; text-decoration: none; text-transform: none; }
body,blockquote { }
</style><!--[if IE 8 ]><div id="ie8-detect"></div><![endif]-->
<!--[if IE 9 ]><div id="ie9-detect"></div><![endif]-->
	</head>

	<body class="post-template-default single single-post postid-12119 single-format-standard custom-background hidpi-on font-st unknown">

		<div id="layout">
		
			<div id="header">

				<div id="header-layout">

					<div id="posts-featured">
												<div class="clear"><!-- --></div>
					</div>

					<div id="header-holder">

						<div id="menu" class="div-as-table no-sticky-menu">
							<div>
								<div>

									<div id="logo" class="div-as-table">
										<div>
											<div>
												<h2><a href="https://currentsauce.com"><img src="https://currentsauce.com/wp-content/uploads/2018/02/Banner-logo.png" data-hidpi="https://currentsauce.com/wp-content/themes/Truemag/assets/images/logo2x.png" alt="Truemag"/></a></h2>											</div>
										</div>
									</div><!-- #logo -->

									<span id="menu-select"></span>
									<div id="menu-box" class="div-as-table"><div><div><nav><ul class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://currentsauce.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://currentsauce.com/category/feature/">Feature</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a  href="https://currentsauce.com/category/arts-living/">Arts &#038; Living</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://currentsauce.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://currentsauce.com/category/opinion/">Viewpoints</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category"><a  href="https://currentsauce.com/category/demon-debates/">Demon Debates</a></li>
</ul></nav></div></div></div>
									<div class="clear"><!-- --></div>
								</div>
							</div>
						</div><!-- #menu -->

						<div class="clear"><!-- --></div>

					</div><!-- #header-holder -->

				</div><!-- #header-layout -->

				<div id="header-layout-2">

					<div id="header-holder-2">

						<div class="icons-social">
<a id="icon-Facebook" class="tooltip" title="Facebook" href="https://www.facebook.com/thecurrentsauce" target="_blank"><!-- --></a>
<a id="icon-Instagram" class="tooltip" title="Instagram" href="https://www.instagram.com/thecurrentsauce/" target="_blank"><!-- --></a>
<a id="icon-Twitter" class="tooltip" title="Twitter" href="https://twitter.com/thecurrentsauce" target="_blank"><!-- --></a></div><div id="menu-2" class=" "><nav><ul class="menu-2"><li><a href="https://currentsauce.com">Home</a></li><li id="menu-item-7909" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7909"><a href="https://currentsauce.com/category/special-editions/">Special Editions</a>
<ul class="sub-menu">
	<li id="menu-item-9945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9945"><a href="https://currentsauce.com/category/satire/">Satire</a></li>
	<li id="menu-item-9846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9846"><a href="https://currentsauce.com/category/special-editions/eco/">ECO</a></li>
	<li id="menu-item-12089" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12089"><a href="https://currentsauce.com/category/special-editions/covid-19-updates/">COVID-19 Updates</a></li>
	<li id="menu-item-7910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7910"><a href="https://currentsauce.com/category/special-editions/sex/">All About Sex</a></li>
</ul>
</li>
<li id="menu-item-8732" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8732"><a href="https://currentsauce.com/category/sga/">Student Government Association</a></li>
<li id="menu-item-9455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9455"><a href="https://currentsauce.com/staff/">Staff</a></li>
</ul></nav></div>
						<form action="https://currentsauce.com/" method="get" role="search" id="search-form-header">
							<span></span>
							<input
								type="text"
								name="s"
								value=""
								placeholder="Search..."
							/>
						</form>

						<div class="clear"><!-- --></div>

					</div><!-- #header-holder-2 -->

					
				</div><!-- #header-layout-2 -->

			</div><!-- #header -->

			<div id="content-parent">
			
				<div id="content-layout">
			<div id="content-holder" class="sidebar-position-none">

				<div id="content-box">
		
					<div>
		
						


										<div id="post-12119" class="post-single post-12119 post type-post status-publish format-standard has-post-thumbnail hentry category-arts-living">

											
													<h1 class="entry-title post-title">Bri’s picks of the week: coming-of-age movies											
													</h1>
												<article>

													

	<div class="st-format-standard-holder"><img width="512" height="512" src="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&amp;ssl=1" class="size-original featured-image wp-post-image jetpack-lazy-image" alt="" data-hidpi="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&amp;ssl=1" data-attachment-id="11367" data-permalink="https://currentsauce.com/cropped-cs-1760497271-1567712504821-png/" data-orig-file="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&amp;ssl=1" data-orig-size="512,512" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-CS-1760497271-1567712504821.png" data-image-description="&lt;p&gt;https://currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png&lt;/p&gt;
" data-medium-file="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?resize=300%2C300&amp;ssl=1" data-large-file="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?w=512&amp;ssl=1 512w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?resize=270%2C270&amp;ssl=1 270w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?resize=192%2C192&amp;ssl=1 192w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?resize=180%2C180&amp;ssl=1 180w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?resize=32%2C32&amp;ssl=1 32w" data-lazy-sizes="(max-width: 512px) 100vw, 512px" data-lazy-src="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=512%2C512&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />	
	</div>
													<div id="article">

														<div class="curre-before-content-2" style="text-align: center; margin-top: 3px; margin-right: 3px; margin-bottom: 3px; margin-left: 3px; " id="curre-631004106"><script id="mNCC" language="javascript">
    medianet_width = "728";
    medianet_height = "90";
    medianet_crid = "894178054";
    medianet_versionId = "3111299"; 
  </script>
<script src="//contextual.media.net/nmedianet.js?cid=8CUO7MHS5"></script></div>
<p><strong>Brianna Corley</strong></p>



<p><em>Arts and Living Editor</em></p>



<p>Coming-of-age&nbsp;is&nbsp;a concept that has filled countless novels and artwork.&nbsp;What films have best shown the many sides and stories of growing into yourself? In this week’s picks, we will be exploring the some of the most impactful coming-of-age movies.</p>



<p><strong>“</strong><strong>Lady Bird</strong><strong>”</strong><strong>&nbsp;– 2017</strong></p>



<p>Following its titular character Christine “Lady Bird” MacPherson throughout her&nbsp;senior year at a&nbsp;Catholic&nbsp;high school, Lady Bird navigates the world with a longing for adventure and opportunity.&nbsp;</p>



<p>While the film covers everything from her first romance to applying to college, it is Lady Bird’s relationship to her mother, who is as a stubborn and loving as she is, that truly makes the story feel real. With an ending that is resolved with the realism of not quite ever truly getting what you want<em>,&nbsp;</em>“Lady Bird”&nbsp;is a must see.</p>



<p><strong>“</strong><strong>Dazed and Confused</strong><strong>”&nbsp;</strong><strong>–</strong><strong>&nbsp;1993</strong></p>



<p>Taking place on the last day of high school for a group of rowdy Austin, Texas,&nbsp;high schoolers in 1969,&nbsp;“Dazed and Confused”exhibits a sense of timeliness in the way it both captures adolescent life in the 70s and how that restlessness&nbsp;still relates to&nbsp;the&nbsp;teenagers&nbsp;of today.&nbsp;</p>



<p>Randall “Pink” Floyd, the star quarterback of the football team, is slowly coming to realize that the high school hierarchy doesn’t matter as he enters senior year while incoming freshmen attempt to avoid being hazed by the incoming seniors.&nbsp;</p>



<p>Even though its only takes place over the course of one day, “Dazed and<em>&nbsp;</em>Confused” paints a raw and vivid picture of the in-betweens of growing up.</p>



<p><strong>“</strong><strong>The Dead Poet’s Society</strong><strong>”</strong><strong>&nbsp;</strong><strong>–</strong><strong>&nbsp;1989</strong></p>



<p>When new English teacher John Keating is hired at an all-boys preparatory school renown for tradition and high standards, students find themselves surprised at his unorthodox methods and wish for them to pursue their dreams and seize the day.&nbsp;</p>



<p>Despite the enormous pressure from their parents and other teachers, the boys regain a lust for life and even restart the dead poet’s society where they read poems by candlelight after curfew. A story about finding yourself and its consequences, “The Dead Poet’s Society’s”<em> </em>end relays an important message.</p>


<div class="none"><time class="date updated" datetime="2020-03-30" data-pubdate>Mar 30, 2020</time><span class="author vcard"><span class="fn">The Current Sauce</span></span></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-12119" class="share-facebook sd-button share-icon no-text" href="https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-12119" class="share-twitter sd-button share-icon no-text" href="https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://currentsauce.com/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class="curre-after-content" style="text-align: center; margin-top: 3px; margin-right: 3px; margin-bottom: 3px; margin-left: 3px; " id="curre-1054722340"><script id="mNCC" language="javascript">
    medianet_width = "728";
    medianet_height = "90";
    medianet_crid = "834268057";
    medianet_versionId = "3111299"; 
  </script>
<script src="//contextual.media.net/nmedianet.js?cid=8CUO7MHS5"></script></div>
														<div class="clear"><!-- --></div>

													</div><!-- #article -->

													
												</article><div id="pre_next_post"><a class="p tooltip" title="Previous" href="https://currentsauce.com/2020/03/29/student-athletes-cope-with-new-reality/">Student athletes cope with new reality</a><a class="n tooltip" title="Next" href="https://currentsauce.com/2020/03/30/its-time-to-close-the-pay-gap/">It’s time to close the pay gap</a><div class="clear"><!-- --></div></div><div class="posts-related-wrapper posts-related-full-wrapper posts-related-2-wrapper">
<h6>You Might Also Like</h6>
<table><tbody><tr><td class="posts-related-post-td-1"><div class="posts-related-post-wrapper"><a href="https://currentsauce.com/2017/09/13/volleyball-faces-tough-competitors/" class="post-thumb post-thumb-standard" data-hidpi="https://i2.wp.com/currentsauce.com/wp-content/uploads/2017/09/8-8-alexis-warren.jpg?resize=524%2C360&ssl=1" style="background-image: url(https://i2.wp.com/currentsauce.com/wp-content/uploads/2017/09/8-8-alexis-warren.jpg?resize=262%2C180&ssl=1)" data-format="standard">&nbsp;</a><div class="posts-related-details-wrapper"><div><h5><a href="https://currentsauce.com/2017/09/13/volleyball-faces-tough-competitors/">Volleyball faces tough competitors</a></h5></div></div></div></td>
<td class="posts-related-post-td-2"><div class="posts-related-post-wrapper"><a href="https://currentsauce.com/2017/03/08/sga-minutes/" class="post-thumb post-thumb-standard" data-hidpi="https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/SGA-Logo.jpg?resize=524%2C360&ssl=1" style="background-image: url(https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/SGA-Logo.jpg?resize=262%2C180&ssl=1)" data-format="standard">&nbsp;</a><div class="posts-related-details-wrapper"><div><h5><a href="https://currentsauce.com/2017/03/08/sga-minutes/">SGA Minutes | Senate approves resolution to improve housing internet</a></h5></div></div></div></td>
</tr></tbody></table><div class="clear"><!-- --></div></div><div class="comments-title-dummy"><!-- --></div>
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Share your thoughts					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=142448836&#038;postid=12119&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=blank&#038;greeting=Share+your+thoughts&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=8.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=c277e1bd14efc1dcb05b89f01d4538c14338787f#parent=https%3A%2F%2Fcurrentsauce.com%2F2020%2F03%2F30%2Fbris-picks-of-the-week-coming-of-age-movies%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
											<div class="clear"><!-- --></div>
		
										</div><!-- #post-% -->



										<div class="sidebar-post">
						
															
														<div class="single-author-info">
				
															<div class="single-author-upic"><a href="https://currentsauce.com/author/thecurrentsauce/"><img alt src="https://secure.gravatar.com/avatar/29bdbf179c81e792cbb60613931f7b33?s=110&#038;d=blank&#038;r=pg" class="avatar avatar-110 photo jetpack-lazy-image" height="110" width="110" data-lazy-srcset="https://secure.gravatar.com/avatar/29bdbf179c81e792cbb60613931f7b33?s=220&#038;d=blank&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/29bdbf179c81e792cbb60613931f7b33?s=110&amp;is-pending-load=1#038;d=blank&#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/29bdbf179c81e792cbb60613931f7b33?s=110&#038;d=blank&#038;r=pg' srcset='https://secure.gravatar.com/avatar/29bdbf179c81e792cbb60613931f7b33?s=220&#038;d=blank&#038;r=pg 2x' class='avatar avatar-110 photo' height='110' width='110' /></noscript></a></div>
										
															<h5><a href="https://currentsauce.com/author/thecurrentsauce/">The Current Sauce</a></h5>
															
															
															<div class="single-author-info-links"><span class="ico16 ico16-facebook"><a target="_blank" href="https://www.facebook.com/thecurrentsauce/" class="tooltip" title="Facebook"></a></span><span class="ico16 ico16-twitter"><a target="_blank" href="https://twitter.com/thecurrentsauce" class="tooltip" title="Twitter"></a></span></div>
															<div class="clear"><!-- --></div>

														</div>
													<div class="post-short-info">

														
				<div class="meta">
			
					<span class="ico16 ico16-calendar">1 day ago</span>										<span class="ico16 ico16-folder"><a href="https://currentsauce.com/category/arts-living/">Arts &amp; Living</a></span>			
				</div><!-- .meta -->
													</div><div><!-- --></div><div id="stickyDiv">
<div id="text-18" class="widget widget_text">
			<div class="textwidget"> <a href="http://strictthemes.com/to/portfolio"><img src="http://img-fotki.yandex.ru/get/9067/231740777.1/0_108dfc_e22febe0_orig" alt data-lazy-src="http://img-fotki.yandex.ru/get/9067/231740777.1/0_108dfc_e22febe0_orig?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="http://img-fotki.yandex.ru/get/9067/231740777.1/0_108dfc_e22febe0_orig" alt="" /></noscript></a></div>
		
<div class="clear"><!-- --></div></div>
</div>						
										</div><!-- .sidebar-post -->



											
						<div class="clear"><!-- --></div>
		
					</div>
			
				</div><!-- #content-box -->

				
				<div class="clear"><!-- --></div>

			</div><!-- #content-holder -->
	
		
				</div><!-- #content-layout -->
		
			</div><!-- #content -->

			<div class="clear"><!-- --></div>

			<footer>

				<div id="footer">
	
					<div id="footer-layout">

						
						<div id="footer-holder">
					
								
	
		<div id="footer-box" class="footer-box-v4"><div class="sidebar-footer"><div>
<div id="text-23" class="widget widget_text">
<h5>About</h5>
			<div class="textwidget"><p><img class="wp-image-1077 alignleft jetpack-lazy-image" src="https://i0.wp.com/currentsauce.com/wp-content/uploads/2018/02/White-logo-no-text.png?resize=75%2C75&#038;ssl=1" alt width="75" height="75" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/currentsauce.com/wp-content/uploads/2018/02/White-logo-no-text.png?resize=75%2C75&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-1077 alignleft" src="https://i0.wp.com/currentsauce.com/wp-content/uploads/2018/02/White-logo-no-text.png?resize=75%2C75&#038;ssl=1" alt="" width="75" height="75" data-recalc-dims="1" /></noscript></p>
<p><strong>The Current Sauce has provided <a href="http://nsula.edu" target="_blank" rel="noopener noreferrer">Northwestern State University</a> with news coverage since 1914.</strong><br />
<strong><a href="https://archive.org/search.php?query=mediatype%3Atexts+AND+collection%3Anorthwesternstate+AND+subject%3A%22newspaper%22&amp;sort=-date&amp;page=1" target="_blank" rel="noopener noreferrer">View our print archives.</a></strong></p>
<p><iframe src="https://www.google.com/maps/d/embed?mid=1aUAU92JfGt3Smg2k_GavLrdVstk"></iframe></p>
</div>
		
<div class="clear"><!-- --></div></div>
</div></div><div class="sidebar-footer"><div>
<div id="text-27" class="widget widget_text">
<h5>Advertising</h5>
			<div class="textwidget"><p><a href="https://currentsauce.com/print-advertising/">Print</a><br />
<a href="https://currentsauce.com/web-advertising/">Web</a></p>
</div>
		
<div class="clear"><!-- --></div></div>
</div></div><div class="sidebar-footer last"><div>
<div id="st_kit_widget widget-info_contact_info-4" class="widget widget-info widget widget-info_st_kit_widget widget-info_contact_info">
<h5>Contact</h5>
<address><p class="widget-info-address"><span>Address: </span>The Current Sauce, Northwestern State University, Natchitoches, LA 71497</p><p class="widget-info-phone"><span>Phone: </span>318-357-5456</p><p class="widget-info-email"><span>Email: </span><a class="mailto" href="mailto:thecurrentsauce@gmail.com">thecurrentsauce@gmail.com</a></p></address>
<div class="clear"><!-- --></div></div>

<div id="text-36" class="widget widget_text">
			<div class="textwidget"><a class="maxbutton-1 maxbutton maxbutton-suggest-a-correction" href="https://currentsauce.com/corrections/"><span class='mb-text'>SUGGEST A CORRECTION</span></a>
</div>
		
<div class="clear"><!-- --></div></div>
</div></div><div class="clear"><!-- --></div>	
		</div><!-- end footer-box -->		
						</div><!-- #footer-holder -->
	
						<div id="copyrights-holder">
	
							<div id="copyrights-box">
						
								<div id="copyrights-company">2020 &copy; The Current Sauce
</div>	
								<div class="clear"><!-- --></div>
	
							</div><!-- #copyrights-box -->
						
						</div><!-- #copyrights-holder -->
	
					</div><!-- #footer-layout -->
	
				</div><!-- #footer -->

			</footer>

		</div><!-- #layout -->

		<!--  -->
<!--noptimize--><!--email_off--><style type='text/css'>.maxbutton-1.maxbutton.maxbutton-suggest-a-correction{position:relative;text-decoration:none;display:inline-block;vertical-align:middle;border-color:#ffffff;width:210px;height:32px;border-top-left-radius:0px;border-top-right-radius:0px;border-bottom-left-radius:0px;border-bottom-right-radius:0px;border-style:solid;border-width:2px;background-color:white;box-shadow:none}.maxbutton-1.maxbutton.maxbutton-suggest-a-correction:hover{border-color:#ffffff;background-color:white;box-shadow:none}.maxbutton-1.maxbutton.maxbutton-suggest-a-correction .mb-text{color:#3c2377;font-family:Verdana;font-size:15px;text-align:center;font-style:normal;font-weight:normal;padding-top:8px;padding-right:0px;padding-bottom:0px;padding-left:0px;line-height:1em;box-sizing:border-box;display:block;background-color:unset}.maxbutton-1.maxbutton.maxbutton-suggest-a-correction:hover .mb-text{color:#3c2377}@media only screen and (max-width:480px){.maxbutton-1.maxbutton.maxbutton-suggest-a-correction{width:90%}.maxbutton-1.maxbutton.maxbutton-suggest-a-correction .mb-text{font-size:12px}}
</style><!--/email_off--><!--/noptimize-->
<div id="pum-9183" class="pum pum-overlay pum-theme-9178 pum-theme-default-theme popmake-overlay pum-click-to-close auto_open click_open" data-popmake="{&quot;id&quot;:9183,&quot;slug&quot;:&quot;newsletter&quot;,&quot;theme_id&quot;:9178,&quot;cookies&quot;:[{&quot;event&quot;:&quot;on_popup_close&quot;,&quot;settings&quot;:{&quot;name&quot;:&quot;pum-9183&quot;,&quot;key&quot;:&quot;&quot;,&quot;time&quot;:&quot;3 months&quot;,&quot;path&quot;:1}}],&quot;triggers&quot;:[{&quot;type&quot;:&quot;auto_open&quot;,&quot;settings&quot;:{&quot;delay&quot;:&quot;500&quot;,&quot;cookie_name&quot;:[&quot;pum-9183&quot;]}},{&quot;type&quot;:&quot;click_open&quot;,&quot;settings&quot;:{&quot;extra_selectors&quot;:&quot;&quot;,&quot;cookie_name&quot;:null}}],&quot;mobile_disabled&quot;:null,&quot;tablet_disabled&quot;:null,&quot;meta&quot;:{&quot;display&quot;:{&quot;responsive_min_width&quot;:false,&quot;responsive_max_width&quot;:false,&quot;position_bottom&quot;:false,&quot;position_left&quot;:false,&quot;position_right&quot;:false,&quot;stackable&quot;:false,&quot;overlay_disabled&quot;:false,&quot;scrollable_content&quot;:false,&quot;disable_reposition&quot;:false,&quot;size&quot;:&quot;normal&quot;,&quot;responsive_min_width_unit&quot;:&quot;px&quot;,&quot;responsive_max_width_unit&quot;:&quot;px&quot;,&quot;custom_width&quot;:&quot;640px&quot;,&quot;custom_width_unit&quot;:false,&quot;custom_height&quot;:&quot;380px&quot;,&quot;custom_height_unit&quot;:false,&quot;custom_height_auto&quot;:false,&quot;location&quot;:&quot;center top&quot;,&quot;position_from_trigger&quot;:false,&quot;position_top&quot;:&quot;50&quot;,&quot;position_fixed&quot;:false,&quot;animation_type&quot;:&quot;fade&quot;,&quot;animation_speed&quot;:&quot;350&quot;,&quot;animation_origin&quot;:&quot;center top&quot;,&quot;overlay_zindex&quot;:&quot;1999999998&quot;,&quot;zindex&quot;:&quot;1999999999&quot;},&quot;close&quot;:{&quot;text&quot;:&quot;X&quot;,&quot;button_delay&quot;:&quot;0&quot;,&quot;overlay_click&quot;:&quot;true&quot;,&quot;esc_press&quot;:&quot;true&quot;,&quot;f4_press&quot;:false},&quot;click_open&quot;:[]}}" role="dialog" aria-hidden="true" >

	<div id="popmake-9183" class="pum-container popmake theme-9178 pum-responsive pum-responsive-normal responsive size-normal">

				

				

		

				<div class="pum-content popmake-content">
			<h2 style="text-align: center;">Sign up for our weekly email newsletter</h2>
<p><div class="tnp tnp-subscription">
<form method="post" action="https://currentsauce.com/?na=s" onsubmit="return newsletter_check(this)">

<input type="hidden" name="nlang" value="">
<input type="hidden" name="nr" value="page">
<div class="tnp-field tnp-field-email"><label>Email</label><input class="tnp-email" type="email" name="ne" required></div>
<div class="tnp-field tnp-field-button"><input class="tnp-submit" type="submit" value="Subscribe" >
</div>
</form>
</div>
</p>
		</div>


				

				            <button type="button" class="pum-close popmake-close" aria-label="Close">
			X            </button>
		
	</div>

</div>
<!-- Your Google Analytics Plugin is missing the tracking ID -->
	<div style="display:none">
	<div class="grofile-hash-map-29bdbf179c81e792cbb60613931f7b33">
	</div>
	</div>
<script type='text/javascript'>/* <![CDATA[ */var stData = new Array();
			stData[0] = "4F3388";
			stData[1] = "3C1E57";
			stData[2] = "https://currentsauce.com/wp-content/themes/Truemag";
			stData[3] = "https://currentsauce.com";
			stData[4] = "12119";
			stData[5] = "https://currentsauce.com/wp-content/plugins";
			stData[6] = "boxed";/* ]]> */</script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/currentsauce.com\/2020\/03\/30\/bris-picks-of-the-week-coming-of-age-movies\/":12119};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2020/03/30/bris-picks-of-the-week-coming-of-age-movies/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://currentsauce.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/currentsauce.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/currentsauce.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/vendors/pnotify/pnotify.min.js?ver=1.0.7'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/vendors/sharer/sharer.js?ver=1.0.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var onionbuzz_lng = {"Correct":"Correct!","Wrong":"Wrong!","Question":"Question","Slide":"Slide","email_form_thank_you":"Thank you, your sign-up request was successful! Please check your e-mail inbox.","email_form_valid_email":"Enter valid email.","quiz_noresult_i_got":"I got","quiz_noresult_of":"of","quiz_noresult_right":"right","quiz_noresult_you_checked":"You checked","quiz_noresult_i_checked":"I checked","quiz_noresult_out_of":"out of","quiz_noresult_on_this_list":"on this list!","quiz_score":"Score:"};
/* ]]> */
</script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/frontend/js/frontend.js?ver=1.0.7'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/stkit/assets/js/jquery.stkit.js'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/stkit/components/shortcodes/assets/js/jquery.shortcodes.js'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/stkit/components/lightbox/assets/js/jquery.prettyPhoto.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Apraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/themes/Truemag/assets/js/jquery.menu.js'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/themes/Truemag/assets/js/jquery.theme.js'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/themes/Truemag/framework/assets/js/jquery.st.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/twitter-timeline.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/newsletter/subscription/validate.js?ver=6.5.8'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/modules/likes/queuehandler.js'></script>
<script type='text/javascript' src='https://currentsauce.com/wp-content/plugins/stkit/assets/plugins/mediaelement/mediaelement-and-player.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pum_vars = {"version":"1.9.2","ajaxurl":"https:\/\/currentsauce.com\/wp-admin\/admin-ajax.php","restapi":"https:\/\/currentsauce.com\/wp-json\/pum\/v1","rest_nonce":null,"default_theme":"9177","debug_mode":"","disable_tracking":"","home_url":"\/","message_position":"top","core_sub_forms_enabled":"1","popups":[]};
var ajaxurl = "https:\/\/currentsauce.com\/wp-admin\/admin-ajax.php";
var pum_sub_vars = {"ajaxurl":"https:\/\/currentsauce.com\/wp-admin\/admin-ajax.php","message_position":"top"};
var pum_popups = {"pum-9183":{"disable_on_mobile":false,"disable_on_tablet":false,"custom_height_auto":false,"scrollable_content":false,"position_from_trigger":false,"position_fixed":false,"overlay_disabled":false,"stackable":false,"disable_reposition":false,"close_on_form_submission":false,"close_on_overlay_click":true,"close_on_esc_press":true,"close_on_f4_press":false,"disable_form_reopen":false,"disable_accessibility":false,"theme_slug":"default-theme","theme_id":9178,"size":"normal","responsive_min_width_unit":"px","responsive_max_width_unit":"px","custom_width":"640px","custom_height":"380px","location":"center top","position_top":"50","animation_type":"fade","animation_speed":"350","animation_origin":"center top","overlay_zindex":"1999999998","zindex":"1999999999","close_button_delay":"0","triggers":[{"type":"auto_open","settings":{"delay":"500","cookie_name":["pum-9183"]}}],"cookies":[{"event":"on_popup_close","settings":{"name":"pum-9183","key":"","time":"3 months","path":1}}],"id":9183,"slug":"newsletter"}};
/* ]]> */
</script>
<script type='text/javascript' src='//currentsauce.com/wp-content/uploads/pum/pum-site-scripts.js?defer&#038;generated=1585219893&#038;ver=1.9.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://currentsauce.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=142448836&postid=12119&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=blank&greeting=Share+your+thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=8.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=c277e1bd14efc1dcb05b89f01d4538c14338787f#parent=https%3A%2F%2Fcurrentsauce.com%2F2020%2F03%2F30%2Fbris-picks-of-the-week-coming-of-age-movies%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=142448836&postid=12119&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=blank&greeting=Share+your+thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=8.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=c277e1bd14efc1dcb05b89f01d4538c14338787f#parent=https%3A%2F%2Fcurrentsauce.com%2F2020%2F03%2F30%2Fbris-picks-of-the-week-coming-of-age-movies%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202014.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'142448836',post:'12119',tz:'-5',srv:'currentsauce.com'} ]);
	_stq.push([ 'clickTrackerInit', '142448836', '12119' ]);
</script>

	</body>

</html>