<!DOCTYPE html>
<html lang="en-US">

<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="generator" content="Unos 2.9.5" />

	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>No one told me how to scary it is to prepare for a hurricane while still in college - The Current Sauce</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="No one told me how to scary it is to prepare for a hurricane while still in college - The Current Sauce" />
	<meta property="og:description" content="Tabatha Bowlin  Contributing Writer In the calm before each natural disaster, does everyone make responsible choices to prepare? Such as finding those flashlights, candles, and batteries. Do they call their insurance provider and make sure that everything is going to be covered if something does happen? Do they prepare an ice chest for perishablesContinue Reading" />
	<meta property="og:url" content="https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/" />
	<meta property="og:site_name" content="The Current Sauce" />
	<meta property="article:publisher" content="https://www.facebook.com/thecurrentsauce/" />
	<meta property="article:author" content="https://www.facebook.com/thecurrentsauce/" />
	<meta property="article:published_time" content="2020-09-08T20:09:26+00:00" />
	<meta property="article:modified_time" content="2020-09-08T20:09:27+00:00" />
	<meta property="og:image" content="https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?fit=1128%2C750&#038;ssl=1" />
	<meta property="og:image:width" content="1128" />
	<meta property="og:image:height" content="750" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@thecurrentsauce" />
	<meta name="twitter:site" content="@thecurrentsauce" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://currentsauce.com/#website","url":"https://currentsauce.com/","name":"The Current Sauce","description":"Northwestern State University&#039;s student newspaper since 1914","potentialAction":[{"@type":"SearchAction","target":"https://currentsauce.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?fit=1128%2C750&ssl=1","width":1128,"height":750},{"@type":"WebPage","@id":"https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/#webpage","url":"https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/","name":"No one told me how to scary it is to prepare for a hurricane while still in college - The Current Sauce","isPartOf":{"@id":"https://currentsauce.com/#website"},"primaryImageOfPage":{"@id":"https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/#primaryimage"},"datePublished":"2020-09-08T20:09:26+00:00","dateModified":"2020-09-08T20:09:27+00:00","author":{"@id":"https://currentsauce.com/#/schema/person/4987d28eec7f99367582230b7d82c41e"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/"]}]},{"@type":"Person","@id":"https://currentsauce.com/#/schema/person/4987d28eec7f99367582230b7d82c41e","name":"The Current Sauce","image":{"@type":"ImageObject","@id":"https://currentsauce.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/29bdbf179c81e792cbb60613931f7b33?s=96&d=blank&r=pg","caption":"The Current Sauce"},"sameAs":["https://www.facebook.com/thecurrentsauce/","https://twitter.com/thecurrentsauce"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The Current Sauce &raquo; Feed" href="https://currentsauce.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Current Sauce &raquo; Comments Feed" href="https://currentsauce.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Current Sauce &raquo; No one told me how to scary it is to prepare for a hurricane while still in college Comments Feed" href="https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/feed/" />
<!-- This site uses the Google Analytics by ExactMetrics plugin v6.2.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.2.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-113901301-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-113901301-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script>
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/currentsauce.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- currentsauce.com is managing ads with Advanced Ads --><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wpcom-text-widget-styles-css'  href='https://currentsauce.com/wp-content/mu-plugins/wpcomsh/vendor/automattic/text-media-widget-styles/css/widget-text.css?ver=20170607' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://currentsauce.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2.2' media='all' />
<link rel='stylesheet' id='onionbuzz-viral-quiz-frontend-css-frontend.css-css'  href='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/frontend/css/frontend.css?ver=1.0.7' media='all' />
<link rel='stylesheet' id='onionbuzz-viral-quiz-vendors-animations-animations.css-css'  href='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/vendors/animations/animations.css?ver=1.0.7' media='all' />
<link rel='stylesheet' id='tt-easy-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Ovo%3Aregular%7CAssistant%3A300%2C600%2C800%2C700&#038;subset=latin%2Call&#038;ver=5.5.1' media='all' />
<link rel='stylesheet' id='unos-googlefont-css'  href='//fonts.googleapis.com/css2?family=Open%20Sans:ital,wght@0,300;0,400;0,500;0,600;0,700;0,800;1,400;1,700' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://currentsauce.com/wp-content/themes/unos/library/fonticons/font-awesome.css?ver=5.0.10' media='all' />
<link rel='stylesheet' id='newsletter-css'  href='https://currentsauce.com/wp-content/plugins/newsletter/style.css?ver=6.8.7' media='all' />
<link rel='stylesheet' id='hoot-style-css'  href='https://currentsauce.com/wp-content/themes/unos/style.css?ver=2.9.5' media='all' />
<link rel='stylesheet' id='hoot-child-style-css'  href='https://currentsauce.com/wp-content/themes/unos-publisher/style.css?ver=1.0.9' media='all' />
<style id='hoot-child-style-inline-css'>
a {
	color: #ffffff;
} 
a:hover {
	color: #bfbfbf;
} 
.accent-typo {
	background: #ffffff;
	color: #630060;
} 
.invert-accent-typo {
	background: #630060;
	color: #ffffff;
} 
.invert-typo {
	color: #ffffff;
} 
.enforce-typo {
	background: #ffffff;
} 
body.wordpress input[type="submit"], body.wordpress #submit, body.wordpress .button {
	border-color: #ffffff;
	background: #630060;
	color: #ffffff;
} 
body.wordpress input[type="submit"]:hover, body.wordpress #submit:hover, body.wordpress .button:hover, body.wordpress input[type="submit"]:focus, body.wordpress #submit:focus, body.wordpress .button:focus {
	color: #630060;
	background: #ffffff;
} 
h1, h2, h3, h4, h5, h6, .title, .titlefont {
	font-family: Georgia, serif;
	text-transform: none;
} 
#main.main,.below-header {
	background: #ffffff;
} 
#topbar {
	background: none;
	color: inherit;
} 
#topbar.js-search .searchform.expand .searchtext {
	background: #ffffff;
} 
#topbar.js-search .searchform.expand .searchtext,#topbar .js-search-placeholder {
	color: inherit;
} 
#site-logo.logo-border {
	border-color: #ffffff;
} 
.header-aside-search.js-search .searchform i.fa-search {
	color: #ffffff;
} 
#site-title {
	font-family: Georgia, serif;
	text-transform: uppercase;
} 
.site-logo-with-icon #site-title i {
	font-size: 50px;
} 
.site-logo-mixed-image img {
	max-width: 200px;
} 
.site-title-line em {
	color: #ffffff;
} 
.site-title-heading-font {
	font-family: Georgia, serif;
} 
.entry-grid .more-link {
	font-family: Georgia, serif;
} 
.menu-items ul {
	background: #ffffff;
} 
.more-link, .more-link a {
	color: #ffffff;
} 
.more-link:hover, .more-link:hover a {
	color: #bfbfbf;
} 
.frontpage-area_c *, .frontpage-area_c .more-link, .frontpage-area_c .more-link a {
	color: #000000;
} 
.sidebar .widget-title,.sub-footer .widget-title, .footer .widget-title {
	background: #630060;
	color: #ffffff;
	border: solid 1px;
	border-color: #ffffff;
} 
.sidebar .widget:hover .widget-title,.sub-footer .widget:hover .widget-title, .footer .widget:hover .widget-title {
	background: #ffffff;
	color: #630060;
} 
.main-content-grid,.widget,.frontpage-area {
	margin-top: 45px;
} 
.widget,.frontpage-area {
	margin-bottom: 45px;
} 
.frontpage-area.module-bg-highlight, .frontpage-area.module-bg-color, .frontpage-area.module-bg-image {
	padding: 45px 0;
} 
.footer .widget {
	margin: 30px 0;
} 
.js-search .searchform.expand .searchtext {
	background: #ffffff;
} 
#infinite-handle span,.lrm-form a.button, .lrm-form button, .lrm-form button[type=submit], .lrm-form #buddypress input[type=submit], .lrm-form input[type=submit],.widget_breadcrumb_navxt .breadcrumbs > .hoot-bcn-pretext {
	background: #ffffff;
	color: #630060;
} 
.woocommerce #respond input#submit.alt, .woocommerce a.button.alt, .woocommerce button.button.alt, .woocommerce input.button.alt {
	border-color: #ffffff;
	background: #ffffff;
	color: #630060;
} 
.woocommerce #respond input#submit.alt:hover, .woocommerce a.button.alt:hover, .woocommerce button.button.alt:hover, .woocommerce input.button.alt:hover {
	background: #630060;
	color: #ffffff;
} 
.widget_breadcrumb_navxt .breadcrumbs > .hoot-bcn-pretext:after {
	border-left-color: #ffffff;
} 
#header,.menu-items > li.current-menu-item:after, .menu-items > li.current-menu-ancestor:after, .menu-items > li:hover:after,.header-supplementary .menu-area-wrap,.menu-hoottag {
	border-color: #ffffff;
} 
.menu-items ul li.current-menu-item, .menu-items ul li.current-menu-ancestor, .menu-items ul li:hover {
	background: #630060;
} 
.menu-items ul li.current-menu-item > a, .menu-items ul li.current-menu-ancestor > a, .menu-items ul li:hover > a {
	color: #ffffff;
} 
#below-header + .main > .loop-meta-wrap, #below-header + .main > .entry-featured-img-headerwrap,.main > .main-content-grid:first-child,.content-frontpage > .frontpage-area-boxed:first-child {
	margin-top: 25px;
} 
@media only screen and (max-width: 969px){
.mobilemenu-fixed .menu-toggle, .mobilemenu-fixed .menu-items {
	background: #ffffff;
} 
.sidebar {
	margin-top: 45px;
} 
.frontpage-widgetarea > div.hgrid > [class*="hgrid-span-"] {
	margin-bottom: 45px;
} 
}
</style>
<link rel='stylesheet' id='st-responsive-css'  href='https://currentsauce.com/wp-content/themes/unos/assets/css/responsive.css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.9.1/_inc/social-logos/social-logos.min.css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.9.1/css/jetpack.css' media='all' />
<script src='https://c0.wp.com/c/5.5.1/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script id='exactmetrics-frontend-script-js-extra'>
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/currentsauce.com","hash_tracking":"false"};
</script>
<script src='https://currentsauce.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js?ver=6.2.2' id='exactmetrics-frontend-script-js'></script>
<link rel="https://api.w.org/" href="https://currentsauce.com/wp-json/" /><link rel="alternate" type="application/json" href="https://currentsauce.com/wp-json/wp/v2/posts/12461" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://currentsauce.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://currentsauce.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p9DHrS-3eZ' />
<link rel="alternate" type="application/json+oembed" href="https://currentsauce.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcurrentsauce.com%2F2020%2F09%2F08%2Fno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://currentsauce.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcurrentsauce.com%2F2020%2F09%2F08%2Fno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college%2F&#038;format=xml" />
<!-- start Simple Custom CSS and JS -->
<style>
.blog #content-container {
width: 100%;
}

.blog #sidebar {
display: none;
}</style>
<!-- end Simple Custom CSS and JS -->

<!-- Onionbuzz Custom CSS -->
<style type="text/css">

</style>
<!-- Onionbuzz Custom CSS END -->
<script type="text/javascript">window.onionbuzz_params = {"ajax_url":"https:\/\/currentsauce.com\/wp-admin\/admin-ajax.php","is_mobile":false};</script><style type='text/css'>img#wpstats{display:none}</style><!-- All in one Favicon 4.7 --><link rel="shortcut icon" href="https://currentsauce.com/wp-content/uploads/2018/02/favicon.ico" />
<link rel="icon" href="https://currentsauce.com/wp-content/uploads/2018/02/favicon-32x32.png" type="image/png"/>
<link rel="apple-touch-icon" href="https://currentsauce.com/wp-content/uploads/2018/02/apple-touch-icon.png" />
<style id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/currentsauce.com/wp-content/uploads/2019/08/cropped-CS-1760497271-1567712504821.png?fit=270%2C270&#038;ssl=1" />
<style id="tt-easy-google-font-styles" type="text/css">p { font-family: 'Ovo'; font-style: normal; font-weight: 400; text-decoration: none; text-transform: none; }
h1 { font-family: 'Assistant'; font-style: normal; font-weight: 300; text-decoration: none; text-transform: none; }
h2 { font-family: 'Assistant'; font-style: normal; font-weight: 600; text-decoration: none; text-transform: none; }
h3 { font-family: 'Assistant'; font-style: normal; font-weight: 800; text-decoration: none; text-transform: none; }
h4 { font-family: 'Assistant'; font-style: normal; font-weight: 800; text-decoration: none; text-transform: none; }
h5 { font-family: 'Assistant'; font-style: normal; font-weight: 700; text-decoration: none; text-transform: uppercase; }
h6 { font-family: 'Assistant'; font-style: normal; font-weight: 800; text-decoration: none; text-transform: none; }
body,blockquote { }
</style></head>

<body class="post-template-default single single-post postid-12461 single-format-standard custom-background wordpress ltr en en-us child-theme logged-out singular singular-post singular-post-12461 hidpi-on" dir="ltr" itemscope="itemscope" itemtype="https://schema.org/Blog">

	
	<a href="#main" class="screen-reader-text">Skip to content</a>

	
	<div id="page-wrapper" class=" site-stretch page-wrapper sitewrap-wide-right sidebarsN sidebars1 hoot-cf7-style hoot-mapp-style hoot-jetpack-style hoot-sticky-sidebar">

		
		<header id="header" class="site-header header-layout-primary-search header-layout-secondary-bottom tablemenu" role="banner" itemscope="itemscope" itemtype="https://schema.org/WPHeader">

			
			<div id="header-primary" class=" header-part header-primary header-primary-search">
				<div class="hgrid">
					<div class="table hgrid-span-12">
							<div id="branding" class="site-branding branding table-cell-mid">
		<div id="site-logo" class="site-logo-text accent-typo with-background logo-border">
			<div id="site-logo-text" class="site-logo-text site-logo-text-medium"><div id="site-title" class="site-title" itemprop="headline"><a href="https://currentsauce.com" rel="home" itemprop="url"><span class="blogname">The Current Sauce</span></a></div><div id="site-description" class="site-description" itemprop="description"><span>Northwestern State University&#039;s student newspaper since 1914</span></div></div>		</div>
	</div><!-- #branding -->
	<div id="header-aside" class=" header-aside table-cell-mid header-aside-search  js-search"><div class="searchbody"><form method="get" class="searchform" action="https://currentsauce.com/" ><label class="screen-reader-text">Search</label><i class="fas fa-search"></i><input type="text" class="searchtext" name="s" placeholder="Type Search Term &hellip;" value="" /><input type="submit" class="submit" name="submit" value="Search" /><span class="js-search-placeholder"></span></form></div><!-- /searchbody --></div>					</div>
				</div>
			</div>

					<div id="header-supplementary" class=" header-part header-supplementary header-supplementary-bottom header-supplementary-center header-supplementary-mobilemenu-fixed">
			<div class="hgrid">
				<div class="hgrid-span-12">
					<div class="menu-area-wrap">
							<div class="screen-reader-text">Primary Navigation Menu</div>
	<nav id="menu-primary" class="menu nav-menu menu-primary mobilemenu-fixed mobilesubmenu-click" role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
		<a class="menu-toggle" href="#"><span class="menu-toggle-text">Menu</span><i class="fas fa-bars"></i></a>

		<ul id="menu-primary-items" class="menu-items sf-menu menu"><li id="menu-item-7746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7746"><a href="https://currentsauce.com/category/news/"><span class="menu-title">News</span><span class="menu-description enforce-body-font">From breaking news to politics, previews and post-coverage, we have you covered for keeping up with all things NSU.</span></a></li>
<li id="menu-item-7750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7750"><a href="https://currentsauce.com/category/feature/"><span class="menu-title">Feature</span><span class="menu-description enforce-body-font">Read character profiles, first-person essays, historic features and more.</span></a></li>
<li id="menu-item-7908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7908"><a href="https://currentsauce.com/category/arts-living/"><span class="menu-title">Arts &#038; Living</span><span class="menu-description enforce-body-font">Read about the arts and entertainment at NSU and in the greater community.</span></a></li>
<li id="menu-item-7749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7749"><a href="https://currentsauce.com/category/sports/"><span class="menu-title">Sports</span><span class="menu-description enforce-body-font">We bring you weekly sports news at NSU including Demons game recaps, athlete and coach profiles, intramural and club sports.</span></a></li>
<li id="menu-item-7751" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7751"><a href="https://currentsauce.com/category/opinion/"><span class="menu-title">Viewpoints</span><span class="menu-description enforce-body-font">Student submissions and editorials relevant to the NSU community appear in this public forum for students’ exclusive use.</span></a></li>
<li id="menu-item-11370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11370"><a href="https://currentsauce.com/category/demon-debates/"><span class="menu-title">Demon Debates</span></a></li>
</ul>
	</nav><!-- #menu-primary -->
						</div>
				</div>
			</div>
		</div>
		
		</header><!-- #header -->

		
		<div id="main" class=" main">
			

<div class="hgrid main-content-grid">

	<main id="content" class="content  hgrid-span-8 has-sidebar layout-wide-right " role="main">
		<div id="content-wrap" class=" content-wrap theiaStickySidebar">

			
				<div id="loop-meta" class="  loop-meta-wrap pageheader-bg-both">
					<div class="hgrid">

						<div class=" loop-meta hgrid-span-12" itemscope="itemscope" itemtype="https://schema.org/WebPageElement">
							<div class="entry-header">

																<h1 class=" loop-title entry-title" itemprop="headline">No one told me how to scary it is to prepare for a hurricane while still in college</h1>

								<div class=" loop-description" itemprop="text"><div class="entry-byline"> <div class="entry-byline-block entry-byline-author"> <span class="entry-byline-label">By:</span> <span class="entry-author" itemprop="author" itemscope="itemscope" itemtype="https://schema.org/Person"><a href="https://currentsauce.com/author/thecurrentsauce/" title="Posts by The Current Sauce" rel="author" class="url fn n" itemprop="url"><span itemprop="name">The Current Sauce</span></a></span> </div> <div class="entry-byline-block entry-byline-date"> <span class="entry-byline-label">On:</span> <time class="entry-published updated" datetime="2020-09-08T15:09:26-05:00" itemprop="datePublished" title="Tuesday, September 8, 2020, 3:09 pm">September 8, 2020</time> </div> <div class="entry-byline-block entry-byline-cats"> <span class="entry-byline-label">In:</span> <a href="https://currentsauce.com/category/opinion/" rel="category tag">Opinion</a> </div><span class="entry-publisher" itemprop="publisher" itemscope="itemscope" itemtype="https://schema.org/Organization"><meta itemprop="name" content="The Current Sauce"><span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""><meta itemprop="width" content=""><meta itemprop="height" content=""></span></span></div><!-- .entry-byline --></div><!-- .loop-description -->
							</div><!-- .entry-header -->
						</div><!-- .loop-meta -->

					</div>
				</div>

			<div itemprop="image" itemscope itemtype="https://schema.org/ImageObject" class="entry-featured-img-wrap"><meta itemprop="url" content="https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?resize=920%2C425&amp;ssl=1"><meta itemprop="width" content="920"><meta itemprop="height" content="425"><img width="920" height="425" src="https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?resize=920%2C425&amp;ssl=1" class="attachment-hoot-wide-thumb entry-content-featured-img wp-post-image jetpack-lazy-image" alt="" loading="lazy" itemscope="" data-attachment-id="12463" data-permalink="https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/prep-pic-1/" data-orig-file="https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?fit=1128%2C750&amp;ssl=1" data-orig-size="1128,750" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="prep pic 1" data-image-description="" data-medium-file="https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?fit=300%2C199&amp;ssl=1" data-large-file="https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?fit=1024%2C681&amp;ssl=1" data-lazy-src="https://i2.wp.com/currentsauce.com/wp-content/uploads/2020/09/prep-pic-1.jpg?resize=920%2C425&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" itemprop="image" /></div>
	<article id="post-12461" class="entry author-thecurrentsauce post-12461 post type-post status-publish format-standard has-post-thumbnail category-opinion" itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost">

		<div class="entry-content" itemprop="articleBody">

			<div class="entry-the-content">
				<div class="curre-before-content-2" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 3px; margin-bottom: 3px; " id="curre-1458688543"><script id="mNCC" language="javascript">
    medianet_width = "728";
    medianet_height = "90";
    medianet_crid = "894178054";
    medianet_versionId = "3111299"; 
  </script>
<script src="//contextual.media.net/nmedianet.js?cid=8CUO7MHS5"></script></div>
<p><strong>Tabatha Bowlin </strong></p>



<p><em>Contributing Writer</em></p>



<p>In the calm before each natural disaster, does everyone make responsible choices to prepare? Such as finding those flashlights, candles, and batteries. Do they call their insurance provider and make sure that everything is going to be covered if something does happen? Do they prepare an ice chest for perishables if they do not own a generator? If they do own a generator, have they checked it?</p>



<p> The list of questions can go on forever depending on each person and their living situation. </p>



<p>I have noticed that a few of my friends were not as concerned as me. They would say things like how they will casually ride out the storm or how they welcome death.  That is not everyone’s point of view, especially mine. Unfortunately, those views do exist nationwide.  </p>



<p>My experience of natural disaster prep was not the best. I didn&#8217;t grow up in Natchitoches, so all of this preparing for the unknown was highly stressful for me. I researched, created an evacuation plan, and asked my parents what to do in various scenarios. I bought two cases of water and jugs for my dog.  </p>



<p>I stocked up on canned food in case of being trapped in my neighborhood by flooding or trees. I feel as if I was preparing for the end of the world. Then the panic started when I realized that I’m a college student who lives off campus and does not have renter’s insurance. I never thought to get it. Losing everything was a possibility and a huge fear. </p>



<p>Human beings are always told to be prepared for anything when it comes to hurricanes, tropical storms, tornados, and any other natural occurrence. How can anyone ever be fully prepared? </p>



<p>The media cannot predict everything.  They only tell us what is happening when they see or hear something from reporters or locals calling in. </p>



<p>Preparation is key to your own survival in my handbook. I hope you choose to create your own survival handbook for your needs before one storm makes it too late. </p>


<div class="none"><time class="date updated" datetime="2020-09-08" data-pubdate>Sep 8, 2020</time><span class="author vcard"><span class="fn">The Current Sauce</span></span></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-12461" class="share-facebook sd-button share-icon no-text" href="https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-12461" class="share-twitter sd-button share-icon no-text" href="https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://currentsauce.com/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class="curre-after-content" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 3px; margin-bottom: 3px; " id="curre-995850082"><script id="mNCC" language="javascript">
    medianet_width = "728";
    medianet_height = "90";
    medianet_crid = "834268057";
    medianet_versionId = "3111299"; 
  </script>
<script src="//contextual.media.net/nmedianet.js?cid=8CUO7MHS5"></script></div>			</div>
					</div><!-- .entry-content -->

		<div class="screen-reader-text" itemprop="datePublished" itemtype="https://schema.org/Date">2020-09-08</div>

		
	</article><!-- .entry -->

<div id="loop-nav-wrap" class="loop-nav"><div class="prev">Previous Post: <a href="https://currentsauce.com/2020/09/03/hurricane-laura-impacts-nsu/" rel="prev">Hurricane Laura impacts NSU</a></div><div class="next">Next Post: <a href="https://currentsauce.com/2020/09/10/sga-opens-up-voting-for-homecoming-nominations/" rel="next">SGA opens up voting for homecoming nominations</a></div></div><!-- .loop-nav -->

<section id="comments-template">

	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Share your thoughts					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=142448836&#038;postid=12461&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=blank&#038;greeting=Share+your+thoughts&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=8.9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=af8cdd6c4c2b412078cbea1e2d342cdfc3629991#parent=https%3A%2F%2Fcurrentsauce.com%2F2020%2F09%2F08%2Fno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college%2F%3Futm_source%3Drss%26utm_medium%3Drss%26utm_campaign%3Dno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</section><!-- #comments-template -->
		</div><!-- #content-wrap -->
	</main><!-- #content -->

	
	<aside id="sidebar-primary" class="sidebar sidebar-primary hgrid-span-4 layout-wide-right " role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
		<div class=" sidebar-wrap theiaStickySidebar">

			<section id="media_image-3" class="widget widget_media_image"><style>.widget.widget_media_image img { height: auto; max-width: 100%; } </style><a href="https://currentsauce.com/web-advertising/"><img width="1042" height="1250" src="https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?fit=1042%2C1250&amp;ssl=1" class="image wp-image-9105  attachment-full size-full jetpack-lazy-image" alt="" loading="lazy" style="max-width: 100%; height: auto;" data-attachment-id="9105" data-permalink="https://currentsauce.com/advanced_ads/sidebar/web-ad-block/" data-orig-file="https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?fit=1042%2C1250&amp;ssl=1" data-orig-size="1042,1250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Web ad block" data-image-description="" data-medium-file="https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?fit=300%2C300&amp;ssl=1" data-large-file="https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?fit=853%2C1024&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?w=1042&amp;ssl=1 1042w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?resize=1030%2C1236&amp;ssl=1 1030w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?resize=850%2C1020&amp;ssl=1 850w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?resize=679%2C815&amp;ssl=1 679w, https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?resize=600%2C720&amp;ssl=1 600w" data-lazy-sizes="(max-width: 1042px) 100vw, 1042px" data-lazy-src="https://i1.wp.com/currentsauce.com/wp-content/uploads/2018/02/Web-ad-block.png?fit=1042%2C1250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></section><section id="text-34" class="widget widget_text">			<div class="textwidget"><p><iframe style="width: 100%; height: 100px;" src="https://tunein.com/embed/player/s34396/" frameborder="no" scrolling="no"></iframe></p>
</div>
		</section><section id="google_translate_widget-2" class="widget widget_google_translate_widget"><div id="google_translate_element"></div></section>
		</div><!-- .sidebar-wrap -->
	</aside><!-- #sidebar-primary -->

	

</div><!-- .main-content-grid -->

		</div><!-- #main -->

		
		
			<div id="post-footer" class=" post-footer hgrid-stretch linkstyle">
		<div class="hgrid">
			<div class="hgrid-span-12">
				<p class="credit small">
					 Designed using <a class="theme-link" href="https://wphoot.com/themes/unos/" title="Unos WordPress Theme">Unos</a>. Powered by <a></a>				</p><!-- .credit -->
			</div>
		</div>
	</div>

	</div><!-- #page-wrapper -->

	<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js'></script>
<!-- Your Google Analytics Plugin is missing the tracking ID -->

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/currentsauce.com\/2020\/09\/08\/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college\/":12461};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/2020/09/08/no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=no-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://currentsauce.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script src='https://c0.wp.com/c/5.5.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script id='hoverIntent-js-extra'>
var hootData = {"stickySidebar":"disable"};
</script>
<script src='https://c0.wp.com/c/5.5.1/wp-includes/js/hoverIntent.min.js' id='hoverIntent-js'></script>
<script src='https://currentsauce.com/wp-content/themes/unos/js/jquery.superfish.js?ver=1.7.5' id='jquery-superfish-js'></script>
<script src='https://currentsauce.com/wp-content/themes/unos/js/jquery.fitvids.js?ver=1.1' id='jquery-fitvids-js'></script>
<script src='https://currentsauce.com/wp-content/themes/unos/js/jquery.parallax.js?ver=1.4.2' id='jquery-parallax-js'></script>
<script src='https://currentsauce.com/wp-content/themes/unos/js/resizesensor.js?ver=1.7.0' id='resizesensor-js'></script>
<script src='https://currentsauce.com/wp-content/themes/unos/js/jquery.theia-sticky-sidebar.js?ver=1.7.0' id='jquery-theia-sticky-sidebar-js'></script>
<script id='contact-form-7-js-extra'>
var wpcf7 = {"apiSettings":{"root":"https:\/\/currentsauce.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
</script>
<script src='https://currentsauce.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2.2' id='contact-form-7-js'></script>
<script id='thickbox-js-extra'>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/currentsauce.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script src='https://c0.wp.com/c/5.5.1/wp-includes/js/thickbox/thickbox.js' id='thickbox-js'></script>
<script src='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/vendors/pnotify/pnotify.min.js?ver=1.0.7' id='onionbuzz-viral-quiz-vendors-pnotify-pnotify.min.js-js'></script>
<script src='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/vendors/sharer/sharer.js?ver=1.0.7' id='onionbuzz-viral-quiz-vendors-sharer-sharer.js-js'></script>
<script id='onionbuzz-viral-quiz-frontend-js-frontend.js-js-extra'>
var onionbuzz_lng = {"Correct":"Correct!","Wrong":"Wrong!","Question":"Question","Slide":"Slide","email_form_thank_you":"Thank you, your sign-up request was successful! Please check your e-mail inbox.","email_form_valid_email":"Enter valid email.","quiz_noresult_i_got":"I got","quiz_noresult_of":"of","quiz_noresult_right":"right","quiz_noresult_you_checked":"You checked","quiz_noresult_i_checked":"I checked","quiz_noresult_out_of":"out of","quiz_noresult_on_this_list":"on this list!","quiz_score":"Score:"};
</script>
<script src='https://currentsauce.com/wp-content/plugins/onionbuzz-viral-quiz/static/frontend/js/frontend.js?ver=1.0.7' id='onionbuzz-viral-quiz-frontend-js-frontend.js-js'></script>
<script src='https://currentsauce.com/wp-content/plugins/stkit/assets/js/jquery.stkit.js' id='st-jquery-stkit-js'></script>
<script id='newsletter-subscription-js-extra'>
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
</script>
<script src='https://currentsauce.com/wp-content/plugins/newsletter/subscription/validate.js?ver=6.8.7' id='newsletter-subscription-js'></script>
<script src='https://currentsauce.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script src='https://currentsauce.com/wp-content/themes/unos/js/hoot.theme.js?ver=2.9.5' id='hoot-theme-js'></script>
<script src='https://c0.wp.com/c/5.5.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" src='https://currentsauce.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script id='google-translate-init-js-extra'>
var _wp_google_translate_widget = {"lang":"en_US","layout":"0"};
</script>
<script src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/widgets/google-translate/google-translate.min.js' id='google-translate-init-js'></script>
<script src='//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit&#038;ver=5.5.1' id='google-translate-js'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://c0.wp.com/p/jetpack/8.9.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=142448836&postid=12461&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=blank&greeting=Share+your+thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=8.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=af8cdd6c4c2b412078cbea1e2d342cdfc3629991#parent=https%3A%2F%2Fcurrentsauce.com%2F2020%2F09%2F08%2Fno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college%2F%3Futm_source%3Drss%26utm_medium%3Drss%26utm_campaign%3Dno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=142448836&postid=12461&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=blank&greeting=Share+your+thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=8.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=af8cdd6c4c2b412078cbea1e2d342cdfc3629991#parent=https%3A%2F%2Fcurrentsauce.com%2F2020%2F09%2F08%2Fno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college%2F%3Futm_source%3Drss%26utm_medium%3Drss%26utm_campaign%3Dno-one-told-me-how-to-scary-it-is-to-prepare-for-a-hurricane-while-still-in-college";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202038.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'142448836',post:'12461',tz:'-5',srv:'currentsauce.com'} ]);
	_stq.push([ 'clickTrackerInit', '142448836', '12461' ]);
</script>

</body>
</html>